Misleading error message when automatically logged out due to inactivity
Incident Report for LeanIX
Resolved
The issue is resolved, the error message should no longer appear.
Posted 7 months ago. Jun 21, 2018 - 22:29 CEST
Identified
Over the past days we activated a new security feature that automatically logs out inactive users from LeanIX. The allowed idle time can be configured by the admin per workspace and is set to 60 minutes as default.

Unfortunately, when automatic logout coincides with session timeout of the IDP provider a technical and hence misleading error message is shown to users. The message reads as follows:

opensaml::FatalProfileException at (https://app.leanix.net/Shibboleth.sso/SLO/Redirect)
... (3 more lines)...
Sub-Status: urn:oasis:names:tc:SAML:2.0:status:UnknownPrincipal

Login to LeanIX is possible at all times, hence the error message can and should be ignored by the users.
We have de-activated the automatic logout feature until we have fixed the issue. However, we expect users to see the above mentioned technical error message once on Friday morning if they have not manually logged off from LeanIX on Thursday night.
Posted 7 months ago. Jun 20, 2018 - 18:24 CEST
This incident affected: Web Application EAM (Europe Instances, Americas Instances, Dedicated Instances).