Long loading of Technology Risk View in large workspaces, partially resulting in timeout
Incident Report for LeanIX
Resolved
The tech-risk view in the application landscape now loads much faster for large-size workspaces. Our test data shows that the view stays below 1 sec in most cases which is a 90x improvement compared to the original implementation. The solution required a fully redesigned version of the graph in order to avoid exponential costs with a growing number of relations between Fact Sheets. To ensure the technology risk always returns with the correct values (also in edge cases) we added numerous automated test cases which will ensure the quality going forward in all future releases of LeanIX.
Posted 4 months ago. Jan 26, 2018 - 19:30 CET
Identified
In workspaces with more than 750 applications, the technology risk view might take long to load, in selected cases a timeout will appear. Our technology risk calculation is happening in real-time against a graph representation. We have identified issues when calculating the risk for workspaces with a huge number of applications linked to IT components. We are currently working with full focus closely together with experts of the graph database to accelerate these cases. We keep you updated.
Posted 4 months ago. Jan 24, 2018 - 00:14 CET