Degraded performance in "Creating a Fact Sheet in the Inventory" functionality

Incident Report for SAP LeanIX

Postmortem

Incident Description

On March 20, 2025, between 9:25 UTC and 10:35 UTC, a limited number of SAP LeanIX customers across seven regions were unable to manually create fact sheets. An error message appeared, indicating that recommendation details could not be loaded, blocking the manual fact sheet creation process.

Incident Resolution

The issue was successfully resolved by reverting the code changes that caused the problem.

Root Cause Analysis

The recommendation system interacted with a downstream service utilizing features not yet launched.

Preventative Measures

We will enhance our automated checks to detect the usage of features that have not yet been released before deploying to production. Additionally, we are refining our alerting system to detect the degradation of the recommendation system more swiftly.

Posted 10 days ago. Mar 26, 2025 - 08:39 UTC

Resolved

On March 20, 2025, between 9:25 UTC and 10:35 UTC, a limited number of SAP LeanIX customers across seven regions were unable to manually create fact sheets. An error message appeared, indicating that recommendation details could not be loaded, blocking the manual fact sheet creation process.
Posted 16 days ago. Mar 20, 2025 - 09:30 UTC