Service Disruption in Roadmap Report
Incident Report for LeanIX
Postmortem

Summary

Between April 02, 09:33 AM UTC and 09:52 PM UTC, Roadmap reports were not loading.

What happened?

In the course of our ongoing technical improvements to the foundational platform, where our suite of reports is generated and run, we have encountered a specific issue. This issue solely impacted the Roadmap report, rendering it unable to load and initialize properly. This was due to certain checkpoints in the restructuring process that, though critical to our infrastructure enhancements, inadvertently interfered with the report's operations. The checkpoints also influenced our alert system, resulting in no alert being thrown.

Mitigation: What did we do about it?

The team rolled back the broken code, which resolved the situation.

Follow-ups: How will we improve?

After mitigation, we thoroughly analyzed why the Roadmap report was affected by these changes and why no alert was thrown. We have already implemented additional Quality Assurance measures to prevent these scenarios.

Posted Apr 09, 2024 - 14:11 CEST

Resolved
This incident has been resolved.
Posted Apr 02, 2024 - 12:58 CEST
Update
We are continuing to monitor for any further issues.
Posted Apr 02, 2024 - 11:54 CEST
Monitoring
We have implemented a fix and have seen full recovery of functionality. We will continue to monitor the situation.
Posted Apr 02, 2024 - 11:53 CEST
Investigating
We are currently experiencing a service disruption in Roadmap Reports. Our team is working to identify the root cause and implement a solution.

We will send an additional update in 30 minutes.
Posted Apr 02, 2024 - 11:46 CEST
This incident affected: EU Instances (EAM), US Instances (EAM), CA Instances (EAM), AU Instances (EAM), DE Instances (EAM), CH Instances (EAM), AE Instances (EAM), UK Instances (EAM), and BR Instances (EAM).