Degraded performance in Portal
Incident Report for LeanIX
Postmortem

Summary

Between March 21, 1:58 PM UTC and March 22, 11:58 AM UTC, uploaded Logos were not visible in Application Portals which caused an error message to be shown.

What happened?

As part of our ongoing commitment to our roadmap, we released the functionality to allow customers to upload logos and display them in the Application Portal.

This release led to an issue where not all users were able to view the logos after uploading them in the Application Portal. Consequently, the logos were not displayed as expected.

Mitigation: What did we do about it?

We solved the issue by releasing a fix to Application Portal.

Follow-ups: How will we improve?

After mitigation, we thoroughly analyzed the reason why this error occurred and identified measures to prevent this issue from happening again.

Posted Mar 26, 2024 - 08:59 CET

Resolved
This incident has been resolved. We appreciate your patience and understanding.
Posted Mar 22, 2024 - 13:32 CET
Monitoring
We have implemented a fix and have seen full recovery of functionality. We will continue to monitor the situation.
Posted Mar 22, 2024 - 13:02 CET
Identified
The issue has been identified and a fix is being implemented.

We will send an additional update in 60 minutes.
Posted Mar 22, 2024 - 10:35 CET
Investigating
Users may experience degraded performance in Portal. Our team is working to identify the root cause and implement a solution.

We will send an additional update in 60 minutes.
Posted Mar 22, 2024 - 09:08 CET
This incident affected: EU Instances (EAM), US Instances (EAM), CA Instances (EAM), AU Instances (EAM), DE Instances (EAM), CH Instances (EAM), AE Instances (EAM), UK Instances (EAM), and BR Instances (EAM).