Service Disruption in Diagrams
Incident Report for SAP LeanIX
Postmortem

Summary

On July 25, 2024, from 15:00 to 15:20 UTC, all workspaces encountered issues with diagrams not loading. This was caused by an error in our deployment pipeline, which resulted in an incorrect editor version deployment.

What happened?

The issue was caused by a misconfiguration in the deployment pipeline, which failed to validate the editor version, leading to the deployment of an incorrect version.

Mitigation: What did we do about it?

The issue was resolved by rolling back to a working editor version and fixing the deployment pipeline.

Follow-up: How will we improve?

We will implement stricter version validation checks in the deployment pipeline to ensure that only verified editor versions are deployed. Additionally, we will enhance monitoring and alerting systems to quickly detect and respond to similar issues in the future.

Posted Jul 29, 2024 - 11:14 UTC

Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 15:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 25, 2024 - 15:21 UTC
Investigating
We are currently experiencing a service disruption in Diagrams. Our team is working to identify the root cause and implement a solution.

We will send an additional update in 30 minutes.
Posted Jul 25, 2024 - 15:17 UTC
This incident affected: EU Instances (EAM), US Instances (EAM), CA Instances (EAM), AU Instances (EAM), DE Instances (EAM), CH Instances (EAM), AE Instances (EAM), UK Instances (EAM), and BR Instances (EAM).