Fact Sheet details page outage

Incident Report for SAP LeanIX

Postmortem

Incident Description

Starting on 2025-05-28 14:56 UTC, LeanIX users experienced errors when attempting to access Fact Sheet details pages within the Inventory. The issue affected all non-admin users across all workspaces and regions.

Incident Resolution

Our engineering team identified the root cause at 2025-05-28 16:13 UTC and ran a rollback of a recent frontend release. Full functionality was restored at 2025-05-28 16:16 UTC. No customer data was affected during this incident.

Root Cause Analysis

The incident was caused by a frontend release that introduced a new internal API call. This call resulted in an authorization error for all non-admin users, leading to the inability to load the Fact Sheet details page. Since the new API call was receiving a HTTP 401 status code response for all non-admin users, the application was starting the re-login procedure. This procedure is not treated as an error & thus - does not trigger alerting mechanisms, which lead to a prolonged detection time.

Preventative Measures

To prevent similar incidents, we are enhancing our pre-release testing protocols to include testing across various user roles and permission levels. We are also improving our frontend application's handling of authorization errors to increase resilience and trigger alerting mechanisms early.

Posted May 30, 2025 - 12:34 UTC

Resolved

This incident has been resolved.
Posted May 28, 2025 - 17:02 UTC

Monitoring

We confirmed that the issue was related to a recent frontend release. The change was reverted and we're currently monitoring the application.
Posted May 28, 2025 - 16:16 UTC

Update

The issue seems to be related to a recent frontend release. No actual customer data is affected/lost.
Posted May 28, 2025 - 16:13 UTC

Investigating

Non-Admin users currently have issues viewing Fact Sheets.
Posted May 28, 2025 - 16:03 UTC
This incident affected: AE Instances, AU Instances, BR Instances, CA Instances, CH Instances, DE instances, EU Instances, JP Instances, SG Instances, UK Instances, and US Instances.