Service Disruption in Surveys

Incident Report for SAP LeanIX

Postmortem

Incident Description

Users were unable to access surveys for approximately 51 minutes on June 23rd, from 09:48 UTC to 10:39 UTC, due to an outage that affected all customers across all regions.

Incident Resolution

Restoring the previous version resolved the service disruption.

Root Cause Analysis

A recent upgrade introduced a software change that didn’t work well with parts of our existing system, which unfortunately caused issues with accessing surveys.

Preventative Measures

We're working on strengthening our testing setup so we can catch potential conflicts between parts of our system early and ensure smoother updates in the future.

Posted Jun 27, 2025 - 08:35 UTC

Resolved

This incident has been resolved. We appreciate your patience and understanding.
Posted Jun 23, 2025 - 09:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results. We will make another update in the next 30 minutes.
Posted Jun 23, 2025 - 08:41 UTC

Investigating

We are currently experiencing a service disruption in Surveys for all workspaces. Our team is working to identify the root cause and implement a solution.

We will send an additional update in 30 minutes.
Posted Jun 23, 2025 - 08:28 UTC
This incident affected: AE Instances, AU Instances, BR Instances, CA Instances, CH Instances, DE instances, EU Instances, JP Instances, SG Instances, UK Instances, and US Instances.