Inventory Table View showing a blank page
Incident Report for SAP LeanIX
Postmortem

Incident Description

From 2024-09-09 at 13:00 UTC until 17:00 UTC there was an issue with the Table view in Inventory, where the page would show a blank page after opening an Inventory Saved Search. After loading the Saved Search, going to list view and then switching back to table view has been a temporary workaround.

Incident Resolution

The incident was resolved after rolling back the identified change.

Root Cause Analysis

We've made a change to the Table UI component in Inventory to improve the performance and memory consumption of the application. The change replaced a certain logic for rendering the table to avoid unnecessary rendering runs and improve overall responsiveness.

Unfortunately, there was an undetected issue when rendering the table after opening an existing Saved Search only, which led to the blank page.

Preventative Measures

We will expand our e2e testing coverage to include stricter validation checks and to prevent such visual regressions from happening again. For future changes like this one, we will use canary releases to mitigate potential customer impact as much as possible before releasing the change to everyone.

Posted Sep 10, 2024 - 12:22 UTC

Resolved
An issue with the Table View in Inventory was introduced, where the page would show a blank page after opening an Inventory Saved Search. After loading the Saved Search, going to list view and then switching back to table view has been a temporary workaround. Issue was resolved at 17:00 UTC.
Posted Sep 09, 2024 - 13:00 UTC