Service Disruption in OData Import on US
Incident Report for SAP LeanIX
Postmortem

Incident Description

In the time from 13 Nov 2024, 09:04 PM UTC to 14 Nov 2024, 00:01 AM UTC, all customers experienced a disruption of data access through the OData bookmark endpoints.

During that time, the OData bookmark endpoints would return an excessive amount of 400 errors.

Incident Resolution

The change causing the service disruption was rolled back at 14 Nov 2024, 00:01 AM UTC.

Root Cause Analysis

The code change that introduced the service disruption extended logs in case of OData endpoint failures. It was small in size, looked harmless as it did not affect business logic and caused no errors during local testing.

We did not further test the code on a production environment and due to an unrelated issue, automated service monitoring was disabled.

Preventative Measures

We plan to reintroduce the service monitoring for 400 and 500 errors as soon as possible. We will also be extending the existing threshold-based alerts to include 400 errors.

Posted Nov 18, 2024 - 12:03 UTC

Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 01:09 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2024 - 00:45 UTC
Update
We are continuing to investigate this issue.
Posted Nov 13, 2024 - 22:49 UTC
Investigating
We are currently experiencing a service disruption in OData Import. Our team is working to identify the root cause and implement a solution.
Posted Nov 13, 2024 - 22:10 UTC
This incident affected: EU Instances (EAM) and US Instances (EAM).