store.leanix.net not reachable

Incident Report for SAP LeanIX

Postmortem

Incident Description

On August 4, 2025, users experienced a disruption to our Store Catalog system. 22 security reports disappeared from the catalog, making them unavailable to users. At the same time, multiple surveys also became inaccessible through our platform.

The incident was first noticed during a routine review when we observed that several assets were missing from the live catalog. This triggered our emergency response procedures to investigate and resolve the issue.

Incident Resolution

After evaluating multiple recovery options, we chose to restore our database from a backup taken before the incident occurred. This approach ensured:

  • Complete recovery of all missing reports and surveys
  • Restoration of full system functionality
  • No permanent data loss

The restoration process required was successfully completed on the morning of August 5th.

Root Cause Analysis

Our automated archival system contained a flawed database query that updated more records than intended. Instead of archiving only the specific reports that met certain criteria, the faulty code archived additional items, including the surveys.

Preventative Measures

To prevent similar incidents in the future, we are implementing the following improvements:

  • Developing better strategies to help our developers identify potential database query issues
  • Enhanced our database restoration procedures for faster recovery if needed
Posted Sep 08, 2025 - 11:38 UTC

Resolved

This incident has been resolved. We appreciate your patience and understanding.
Posted Aug 05, 2025 - 09:17 UTC

Investigating

We are currently experiencing a disruption of store.leanix.net. Our team is working to identify the root cause and implement a solution. Using or maintaining already installed custom reports and survey templates in workspaces are not affected.

We will send an additional update in 2 hour.
Posted Aug 05, 2025 - 07:11 UTC
This incident affected: Website.