Service Disruption in DE

Incident Report for SAP LeanIX

Postmortem

Incident Description

On 2 Oct 2025 between 15:16 and 15:31 UTC, users accessing de.leanix.net may have experienced a partial outage when accessing the Inventory.

Incident Resolution

The affected system was identified and restarted.

Root Cause Analysis

The affected system was heavily used with many customers changes and updates being processed at the same time. With many processors handling updates asynchronously the overall performance degraded.

Preventative Measures

We improved parallel processing capabilities in our system to allow faster handling of updates. We also improved the integration between different system components to improve updates processing performance.

Posted Oct 16, 2025 - 13:54 UTC

Resolved

Some customers in DE region may have experienced service disruption while accessing Inventory. This incident only affected customers hosted on instance de.leanix.net.

The service disruption started at 17:16 CEST and was resolved at 17:31 CEST.
Posted Oct 02, 2025 - 15:00 UTC