EAM - Degraded performance in Webhooks
Incident Report for LeanIX
Postmortem

Summary

Between March 11, 02:49 PM UTC and March 12, 10:00 AM UTC, processing time of webhooks events increased significantly - resulting in delayed event deliveries towards our customers.

What happened?

The underlying database behind the webhooks service was getting slower, even though enough resources were available to the database. The database process that takes care of updating statistics to build optimized queries was not executed for a longer period of time due to an unoptimized configuration, which caused the database to execute inefficient queries.

Mitigation: What did we do about it?

The process of updating the database query statistics was triggered manually.

Follow-ups: How will we improve?

After the incident, the alerting on the webhooks event processing was improved. To resolve the problem, we improved the database configuration.

Posted May 03, 2024 - 16:49 CEST

Resolved
This incident has been resolved.
Posted Mar 12, 2024 - 13:45 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 12, 2024 - 10:31 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 12, 2024 - 09:22 CET
Investigating
Users may experience degraded performance with Webhooks events. Our team is working to identify the root cause and implement a solution.

We will send an additional update in 90 minutes.
Posted Mar 12, 2024 - 07:24 CET
This incident affected: US Instances (EAM).