Editing fact sheets through table view is not working

Incident Report for SAP LeanIX

Postmortem

Incident Description

On 2025-04-28, between 12:40 and 14:14 UTC, editing fact sheets through the table view was not possible within SAP LeanIX. When users tried to save the changes made on multiple fact sheets through Inventory’s table view, they received an error.

Incident Resolution

Our team identified and mitigated the issue. The degraded service experience was resolved at 14:14 UTC.

Root Cause Analysis

A missing check for empty data caused an error when the users tried to save the changes made through the fact sheets table view, leading to an error message being shown to the users.

Preventative Measures

After the incident, we took steps to understand why we were unable to catch the error earlier. We have identified areas for improvement and are currently working on:

  • Improving processes for faster time to recovery.
  • Improve test coverage on our frontend components.
Posted May 08, 2025 - 07:23 UTC

Resolved

Editing fact sheets through the table view was not possible within SAP LeanIX. When users tried to save the changes made on multiple fact sheets through Inventory’s table view, they received an error.
Posted Apr 28, 2025 - 12:30 UTC