Service Disruption In EU region

Incident Report for SAP LeanIX

Postmortem

Incident Description

On 17 Jun 2025 between 09:11 and 09:43 UTC, users in the EU region might have not been able to access SAP LeanIX. The browsers showed a white page instead of the SAP LeanIX frontend.

Incident Resolution

The issue was resolved by clearing the caches in our CDN component, responsible for delivering the frontend assets to the users' browser.

Root Cause Analysis

At 09:11 an incomplete index.html file was cached by our CDN, due to a misconfiguration in the caching logic. Subsequent requests to load the index.html by the users' browser were served from the cache, returning the invalid index.html.

Preventative Measures

We removed the caching logic responsible for caching incomplete files.

Posted Jun 23, 2025 - 07:03 UTC

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 10:01 UTC

Monitoring

A fix has be implemented and we are monitoring the results.
Posted Jun 17, 2025 - 09:47 UTC

Investigating

We are currently experiencing a service disruption in EU region. Our team is working to identify the root cause and implement a solution.

We will send an additional update in 60 minutes.
Posted Jun 17, 2025 - 09:42 UTC
This incident affected: EU Instances.