Login issues

Incident Report for SAP LeanIX

Postmortem

Incident Description

On April 30, 2025, at 11:30 AM, users encountered login issues while trying to access the LeanIX platform. The Issue only affected non SSO customer.

Incident Resolution

By 11:53 AM on the same day, the problematic code was rolled back, successfully restoring functionality. The issue was subsequently resolved and redeployed without any further complications.

Root Cause Analysis

The incident was traced back to a bug in the user validation process that was introduced in preparation for the LeanIX sign-in rollout and its enhanced capabilities. This bug caused our User Management system (MTM) to reject logins from the LeanIX sign-in process.

Preventative Measures

The bug originated from an authentication workflow that involved multiple services. We will ensure the tests in the involved services are matching the expected interface contract.

Posted May 07, 2025 - 11:31 UTC

Resolved

This incident has been resolved. We appreciate your patience and understanding.
Posted Apr 30, 2025 - 12:38 UTC

Monitoring

We have implemented a fix and have seen full recovery of functionality. We will continue to monitor the situation.
Posted Apr 30, 2025 - 11:55 UTC

Update

We are continuing to investigate this issue.
Posted Apr 30, 2025 - 11:46 UTC

Investigating

Some users may experience problems while logging in to our application. Our team is working to identify the root cause and implement a solution.

We will send an additional update in 15 minutes.
Posted Apr 30, 2025 - 11:46 UTC
This incident affected: EU Instances (EAM), US Instances (EAM), CA Instances (EAM), AU Instances (EAM), DE Instances (EAM), CH Instances (EAM), AE Instances (EAM), UK Instances (EAM), BR Instances (EAM), SG Instances (EAM), and JP Instances (EAM).