Degraded performance in Signavio Integration Configuration UI in EU

Incident Report for SAP LeanIX

Postmortem

Incident Description

On April 07, 2025, between 01:40 PM and 03:10 PM UTC, users were unable to set up or update a Signavio Integration in the EU region.

Incident Resolution

Redeploying the service successfully restored the availability of the functionality.

Root Cause Analysis

Parts of the Signavio integration became unavailable due to an unexpected surge in load, which exhausted available connections and rendered the service unresponsive.

Preventative Measures

We will scale up the resources allocated to this service to ensure it can reliably handle similar load levels in the future. We will continue to enhance our observability to detect and respond to connection issues more proactively and minimize impact.

Posted Apr 17, 2025 - 07:56 UTC

Resolved

This incident has been resolved.
Posted Apr 07, 2025 - 15:27 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2025 - 15:24 UTC

Identified

Users may not be able to access the Signavio Integration Configuration UI. The root cause has been identified. Our team is working on a solution.
Posted Apr 07, 2025 - 15:19 UTC
This incident affected: EU Instances (EAM).