Degraded performance in Collections

Incident Report for SAP LeanIX

Postmortem

Incident Description

Multiple customers in EU, US, DE, UK and CH regions were not able use Collections across Diagrams, Reports and Dashboards. Service degradation lasted from Jan 17, 2025 09:25 UTC to Jan 17, 2025 09:52 UTC (27 mins). There was no data loss.

Incident Resolution

We reverted changes that caused the issue. It was resolved at Jan 17, 2025 09:52 UTC.

Root Cause Analysis

We introduced a new feature to navigation item search API endpoint. Even though we had tests in place, one of the cases was not covered and caused an issue when a specific parameter was included in the API request.

Preventative Measures

We will extend our testing strategy by including additional test types and canary releases to prevent similar regressions in the future.

Posted Feb 10, 2025 - 15:35 UTC

Resolved

Multiple customers in EU, US, DE, UK and CH regions were not able use Collections across Diagrams, Reports and Dashboards. Service degradation lasted from Jan 17, 2025 09:25 UTC to Jan 17, 2025 09:52 UTC (27 mins). There was no data loss.
Posted Jan 17, 2025 - 08:30 UTC