Completion score on Business Capabilities temporarily wrong
Incident Report for SAP LeanIX
Postmortem

Incident Description

Between 2025-01-14 15:03 UTC and 2025-01-15 05:55 UTC users experienced that completion scores on Business Capability fact sheets showed a lower value than expected.

Incident Resolution

We deployed a fix that changed the completion score shown in the fact sheet details page, in reports, dashboards and Excel exports back to its expected value. However, for some workspaces it could take multiple hours to propagate the updated completion score to the secondary data store that feeds the search and the table view in the inventory.

Root Cause Analysis

We rolled out a modification to the meta model of the Business Capability fact sheet to introduce new fields that we announced before. However, we missed detecting in our code review that a new field had a default completion weight of 1, which reduced the overall completion score of all Business Capability fact sheets in all workspaces.

Preventative Measures

We plan to be more diligent when we introduce new fields to fact sheets. For meta model modifications governed by SAP LeanIX the default completion weight will be 0 instead of 1.

Posted Jan 22, 2025 - 11:30 UTC

Resolved
All completion scores on business capabilities have been restored.
Posted Jan 15, 2025 - 05:55 UTC
Monitoring
75% of all workspaces have been reverted to the correct completion score in the inventory list and table view. We expect all workspaces to be corrected at 7 am UTC tomorrow.
Posted Jan 14, 2025 - 20:42 UTC
Update
We fixed the completion scores on the fact sheet details page and in reports. We are currently rolling out the same fix for the inventory list and table view. We will send an update in approx. 2 hours.
Posted Jan 14, 2025 - 18:21 UTC
Identified
Users experience an unintended change of the completion score on Business Capability fact sheets. We are in the process of reverting this change.
We will send an additional update in 2 hours.
Posted Jan 14, 2025 - 17:02 UTC
This incident affected: EU Instances (EAM), US Instances (EAM), CA Instances (EAM), AU Instances (EAM), DE Instances (EAM), CH Instances (EAM), AE Instances (EAM), UK Instances (EAM), BR Instances (EAM), and SG Instances (EAM).