Default relations are ignored in Excel and OData export

Incident Report for SAP LeanIX

Postmortem

Incident Description

On April 14, 2025, between 11:51 UTC and 16:09 UTC, customers experienced issues with Excel exports in which default relations were missing from the exported data. This issue was introduced by a change made to label placeholder handling in the import-export service, as a follow-up to a previous fix related to the OData integration.

Incident Resolution

The issue was identified shortly after a customer report and was confirmed to be linked to a recent code change. The change was promptly reverted, and a fix was deployed across all regions by 16:09 UTC. The export functionality was restored, and the incident was marked as resolved after a brief monitoring period.

Root Cause Analysis

The placeholder update introduced in the import-export service unintentionally affected the export of default relations. The change was protected by a feature flag, but the behaviour with default relations didn't have enough test coverage. This allowed the issue to pass unnoticed until reported by a customer.

Preventative Measures

To prevent similar issues in the future, the following actions will be taken:

  • Improve test coverage to include default relations in export scenarios.
  • Conduct more thorough manual testing for critical features before deployment.
Posted Apr 17, 2025 - 08:00 UTC

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 17:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2025 - 16:11 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 14, 2025 - 15:48 UTC

Investigating

We are currently investing an issue in the Excel and OData export functionality. At the moment, certain relations are being ignored in the export result (e.g. Parents, Successors).

We will send an update on the issue in 30 minutes.
Posted Apr 14, 2025 - 15:32 UTC
This incident affected: EU Instances (EAM), US Instances (EAM), CA Instances (EAM), AU Instances (EAM), DE Instances (EAM), CH Instances (EAM), AE Instances (EAM), UK Instances (EAM), BR Instances (EAM), SG Instances (EAM), and JP Instances (EAM).