Service Disruption in EU region
Incident Report for SAP LeanIX
Postmortem

Incident Description

On November 13, 2024, between 09:26 and 09:32 UTC, our Multi Tenancy Manager (MTM) API in EU experienced an outage. This disruption prevented users from logging in and accessing their workspaces.

Incident Resolution

The system recovered itself.

Root Cause Analysis

A process in the MTM service locked a database table for updates, which blocked other requests from being executed. After the lock was released, requests could access the table again.

Preventative Measures

We are enhancing our monitoring of long-running processes and the locks they create on the database.

Posted Nov 18, 2024 - 08:47 UTC

Resolved
This incident has been resolved.
Posted Sep 09, 2024 - 15:48 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2024 - 15:27 UTC
Investigating
We are currently experiencing a service disruption in EU. Our team is working to identify the root cause and implement a solution.

We will send an additional update in 60 minutes.
Posted Sep 09, 2024 - 15:08 UTC
This incident affected: EU Instances (EAM).