Service Disruption in **Teams Chat Bot**

Incident Report for SAP LeanIX

Postmortem

Incident Description

From 2025-04-16 13:10 UTC to 2025-04-17 11:36 UTC, users of the SAP LeanIX MS Teams Chatbot were unable to log in due to a missing configuration update on the Azure Bot resource. This issue affected all users of the Microsoft Teams application. During the incident, users were unable to authenticate, switch workspaces to enable notifications, or use search functionalities for fact sheets within the chatbot.

Incident Resolution

We applied a configuration fix to the Azure Bot resource to restore proper authentication. Once the fix was implemented, the incident was resolved, and users regained full access to chatbot functionality.

Root Cause Analysis

The root cause was a misalignment between the configuration of our internal system and the Azure resource, resulting from a missed synchronization step.

Preventative Measures

We have enhanced internal documentation and configured automatic trigger updates to the MS Teams Chatbot Azure resource when infrastructure changes occur. This reduces the risk of future missed updates.

Posted Apr 28, 2025 - 14:47 UTC

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 13:10 UTC