Degraded performance in Dashboards

Incident Report for SAP LeanIX

Postmortem

Incident Description

From 2025-08-01 04:19 UTC to 2025-08-04 07:44 UTC, users experienced incorrect filter application when navigating from pie charts on dashboards to inventory views. Specifically, clicking on pie chart segments applied wrong or empty filters, causing inventory results to be incomplete or missing.

During this time, users were advised to manually reapply filters as a workaround. This issue was isolated to pie charts; other chart types, such as column and horizontal bar charts, were unaffected.

Incident Resolution

The root cause was identified as a breaking behavioral change introduced in Highcharts v12, where pie chart categories switched from string labels to numeric indexes by default. Our filtering logic used these category values to apply filters during navigation, but received numeric indexes instead of meaningful filter keys.

The fix updated chart click handlers to use the explicit category field from chart point options, restoring correct filter behavior. This update was tested across all chart types and deployed successfully on 2025-08-04 07:44 UTC.

Root Cause Analysis

The incident resulted from an undocumented change in a third-party library during a major version upgrade. Our filtering logic was designed around the previous behavior, which went unnoticed during testing. This caused filter failures for pie chart interactions only.

Preventative Measures

  • Strengthen testing coverage on chart interaction behaviors across all chart types by improving unit tests around navigation and filtering logic to detect discrepancies early.
  • Enhance review processes for third-party upgrades by ensuring chart action validation during both implementation and review phases.
Posted Aug 14, 2025 - 13:54 UTC

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 08:01 UTC

Investigating

Users may experience a problem when navigating from Dashboards. The issue may cause wrong filters to be applied in Inventory and users are requested to re-apply any filters manually.
Posted Aug 01, 2025 - 21:13 UTC
This incident affected: AE Instances, AU Instances, BR Instances, CA Instances, CH Instances, DE instances, EU Instances, JP Instances, SG Instances, UK Instances, and US Instances.