invitation of new users to a workspace not possible

Incident Report for SAP LeanIX

Postmortem

Incident Description

Between 2025-05-07 13:55 and 2025-05-08 06:07 UTC, users of SAP LeanIX were not able to invite other users to a workspace.

Incident Resolution

The incident was resolved by a rollback, reverting the code change causing the issue.

Root Cause Analysis

The incident was traced back to a change in the frontend code, which switched the user search functionality to a new API endpoint. This switch was incompatible with the parameters used by user invitation functionality.

Preventative Measures

To avoid encountering similar issues in the future, we will enhance the scope of our automated tests to include the parameters used in API calls by the user invitation functionality.

Posted May 12, 2025 - 13:11 UTC

Resolved

This incident has been resolved, and the invitation of users to workspaces is working again.
Posted May 08, 2025 - 06:30 UTC

Investigating

It is currently not possible to invite new users into a workspace of our application. Our team is working to identify the root cause and implement a solution.
Posted May 07, 2025 - 20:48 UTC
This incident affected: EU Instances (EAM), US Instances (EAM), CA Instances (EAM), AU Instances (EAM), DE Instances (EAM), CH Instances (EAM), AE Instances (EAM), UK Instances (EAM), BR Instances (EAM), SG Instances (EAM), JP Instances (EAM), and Website.