Unable to link individual fact sheets to reference catalogs

Incident Report for SAP LeanIX

Postmortem

Incident Description

Between 24 Jun 2025 14:20 UTC and 25 Jun 2025 07:27 UTC, SAP LeanIX users could not link Fact Sheets to Reference Catalogs via the "Start Linking" button for Application and IT Component Fact Sheet types on Fact Sheet Details page.

Incident Resolution

Restoring the previous version resolved the service disruption.

Root Cause Analysis

As part of implementing a new feature, a change was made to a shared UI component, which accidentally disabled an existing feature that depended on the component.

Preventative Measures

  • We will close gaps in our automated tests
  • We will re-assess our UI component architecture to check if we can limit unintended side effects
Posted Jul 07, 2025 - 14:50 UTC

Resolved

This incident has been resolved. We appreciate your patience and understanding.
Posted Jun 25, 2025 - 08:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results. We will make another update in the next 30 minutes.
Posted Jun 25, 2025 - 07:13 UTC

Investigating

Users may be unable to link individual fact sheets to the reference catalog from the fact sheet page. Our team is working to identify the root cause and implement a solution.

Workaround: Fact sheets can still be linked to the reference catalog using the bulk linking features.
- https://docs-eam.leanix.net/docs/saas-catalog#bulk-linking-application-fact-sheets-from-the-inventory
- https://docs-eam.leanix.net/docs/lifecycle-catalog#bulk-linking-it-component-fact-sheets-from-the-inventory

We will send an additional update at 8 am UTC.
Posted Jun 24, 2025 - 21:44 UTC
This incident affected: AE Instances, AU Instances, BR Instances, CA Instances, CH Instances, DE instances, EU Instances, JP Instances, SG Instances, UK Instances, and US Instances.