Tag filters not working in Inventory, Reports & Diagrams

Incident Report for SAP LeanIX

Postmortem

Incident Description

On February 17, 2025 between 10:30 and 13:00 UTC tag group filters were not visible within the inventory filters. As a result and during that period, users were not able to use any tag group filters when filtering fact sheets on the inventory view.

Incident Resolution

The incident was caused by a software release which was reverted and the previous version deployed.

Root Cause Analysis

The root cause of the problem was an unexpected side affect of a change meant to prevent errors while creating tag group filters in the inventory.

Preventative Measures

We’ve extended our test coverage to prevent introducing such regressions when working with tag group filters.

Posted Feb 20, 2025 - 14:14 UTC

Resolved

This incident has been resolved.
Posted Feb 17, 2025 - 14:53 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2025 - 13:39 UTC

Investigating

Currently, tag filters are not shown in the Inventory, Reports & Diagrams. The team is actively investigating the issue.

We will send an additional update in 30 minutes.
Posted Feb 17, 2025 - 12:59 UTC
This incident affected: EU Instances (EAM), US Instances (EAM), CA Instances (EAM), AU Instances (EAM), DE Instances (EAM), CH Instances (EAM), AE Instances (EAM), UK Instances (EAM), BR Instances (EAM), SG Instances (EAM), and JP Instances (EAM).