Degraded performance in Dashboards

Incident Report for SAP LeanIX

Postmortem

Incident Description

Since 23 Jun 2025, some SAP LeanIX users have experienced inconsistencies in the reports on dashboards. Specifically, reports were intermittently displayed with a different configuration than was configured in the dashboard, temporarily resolvable through a page refresh.

Incident Resolution

Reverting the most recent changes has successfully resolved the inconsistency in the dashboard reports. Full functionality has been completely restored at 2025-06-24 18:30 UTC.

Root Cause Analysis

The issue arose from a race condition that occurred following the enhancements and bug fixes implemented on 12 Jun 2022. This race condition affected the reports displayed within the dashboards.

Due to the complexity and diversity of report configurations, this race condition went undetected during our testing processes.

Preventative Measures

To mitigate the risk of similar incidents occurring in the future, we will enhance our pre-release testing protocols by incorporating additional automatic testing across different report containers.

Posted Jul 01, 2025 - 07:50 UTC

Resolved

This incident has been resolved. We appreciate your patience and understanding.
Posted Jun 25, 2025 - 09:12 UTC

Update

We are continuing to investigate this issue.
Posted Jun 24, 2025 - 14:26 UTC

Update

We are continuing to investigate this issue.
Posted Jun 24, 2025 - 11:24 UTC

Update

We are continuing to investigate this issue.
Posted Jun 24, 2025 - 10:10 UTC

Investigating

Users may experience dashboards with a different format than the ones they have configured.

We will send an additional update in 60 minutes.
Posted Jun 24, 2025 - 09:32 UTC
This incident affected: AE Instances, AU Instances, BR Instances, CA Instances, CH Instances, DE instances, EU Instances, JP Instances, SG Instances, UK Instances, and US Instances.