Service Disruption in EU

Incident Report for SAP LeanIX

Postmortem

Incident Description

Between 8 Jun 2025 09:51 UTC and 8 Jun 2025 10:13 UTC, SAP LeanIX users might have experienced failed login attempts and errors when searching for users.

Incident Resolution

Our engineering team resolved a lock on the database, which fully restored the functionality.

Root Cause Analysis

The incident was caused by a Object-Relational Mapping (ORM) system, which created a new constraint on the database, leading to a lock. This lock was released at 8 Jun 2025 10:13 UTC.

Preventative Measures

To prevent similar incidents, we are disabling the database change functionality of the ORM. This ensures that database schema changes are only done via the database migration system.

Posted Jun 16, 2025 - 11:50 UTC

Resolved

This incident has been resolved. We appreciate your patience and understanding.
Posted Jun 08, 2025 - 09:51 UTC