Temporary disruption on the Fact Sheet details page

Incident Report for SAP LeanIX

Postmortem

Incident Description

On March 14, 2025, between 12:41 UTC and 13:31 UTC, SAP LeanIX customers across all regions experienced an error message when opening the fact sheet details page. The message left the users with the assumption that the page was broken. Even after acknowledging the error, the page was operational.
The error message was only shown to users who accessed the page with a VIEWER-only role.

Incident Resolution

The issue was resolved successfully by providing a fix for the broken sidebar component that caused the error to be shown.

Root Cause Analysis

The issue was introduced when changing a sidebar component that did not initialize properly for users in the VIEWER role under certain conditions.

Preventative Measures

We will enhance test coverage for users with least-privilege access and expand our efforts to identify improperly initialized components using static code analysis.

Posted Mar 25, 2025 - 15:53 UTC

Resolved

We had a temporary disruption on the Fact Sheet details page of all workspaces, between 13:33 MEZ & 14:41 MEZ. This has been mitigated and resolved. We will investigate thoroughly how to avoid this affecting our customers in the future. Our apologies for the inconvenience.
Posted Mar 14, 2025 - 00:30 UTC