Faulty support for DE, ES, FR, PT languages

Incident Report for SAP LeanIX

Postmortem

Incident Description

Between April 30 and May 9, customers using non-English display languages experienced unexpected changes in the translation of key product terminology. This affected the user experience by presenting unfamiliar translations for commonly used terms.

Incident Resolution

Upon receiving customer feedback about problematic translations, we immediately reverted all the translation changes. By May 9, all affected translations were restored to their original state.

Root Cause Analysis

The incident occurred during the transition to a new translation management system and external professional translators. Up to this point, all translations were done internally by native speakers within SAP LeanIX. Due to limited capacity, the number of untranslated strings grew significantly over time and the introduction of new UI languages was not possible. During this transition, existing terminology was modified despite the context of established terms that had been provided. This resulted in technically correct but contextually disruptive translations.

Preventative Measures

To prevent similar issues in the future, we will:

  • Improve our translation review process before releasing updates
  • Create clearer guidelines about preserving established product terms
  • Strengthen communication between our team and translation service providers
Posted May 14, 2025 - 11:53 UTC

Resolved

On April 30th we extended our support for German, Spanish, French and Portuguese languages in SAP LeanIX. We identified some faulty translations and reverted those languages to the previous state.

We apologize for any inconvenience this may have caused.
Posted Apr 30, 2025 - 10:00 UTC