Access of Menu items shows errors

Incident Report for SAP LeanIX

Postmortem

Incident Description

Between April 8, 10:35 AM UTC and 11:48 AM UTC, there was a degraded experience of our user interface for Surveys, Diagrams, Presentations, Reports and Transformations.

Incident Resolution

Our team identified the offending release and rolled it back. Service degraded experience was resolved at 11:48 UTC.

Root Cause Analysis

A broken user image component release in the morning caused a flaw in the internal dependency linking, leading to the error messages being shown to our users and user images not being rendered on the page.

Preventative Measures

After the incident, we took steps to understand why we haven't caught the error earlier in our deployment pipeline. We have identified areas for improvement and are currently working on:

  • Improving our testing strategy to catch such dependency related failures
  • Improving processes for faster time until recovery
Posted Apr 17, 2025 - 07:58 UTC

Resolved

This incident has been resolved.
Posted Apr 08, 2025 - 11:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2025 - 11:41 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 08, 2025 - 11:23 UTC

Update

We are continuing to investigate this issue.
Posted Apr 08, 2025 - 11:17 UTC

Investigating

Users may encounter errors when accessing Reports, Diagrams, Surveys, and other menu items. Our team is working to identify the root cause and implement a solution.
Posted Apr 08, 2025 - 11:14 UTC
This incident affected: EU Instances (EAM), US Instances (EAM), CA Instances (EAM), AU Instances (EAM), DE Instances (EAM), CH Instances (EAM), AE Instances (EAM), UK Instances (EAM), BR Instances (EAM), SG Instances (EAM), and JP Instances (EAM).