Service Disruption in US

Incident Report for SAP LeanIX

Postmortem

Incident Description

On July 24, 2025, the Pathfinder instance us.leanix.net was unavailable for approximately 6 minutes, from 12:30:50 UTC to 12:36:40 UTC. All customer requests targeting this instance failed. At least seven customers have been affected.

Incident Resolution

The issue was mitigated by redeploying the affected instance.

Root Cause Analysis

During a routine update, one of our gateway servers reloaded its configuration. Due to connectivity issues, the server was unable to reach any DNS servers, resulting in its failure to resolve the IP address of the upstream server. Consequently, the web server was not able to respond to requests to the respective upstream service.

Preventative Measures

We will utilize Azure’s internal DNS servers to reduce latency and dependency on internet connectivity. Furthermore, we will consider hot reloads in scenarios like this to improve recovery times.

Posted Jul 29, 2025 - 07:51 UTC

Resolved

On July 24, 2025, the Pathfinder instance us.leanix.net was unavailable for approximately 6 minutes, from 12:30:50 UTC to 12:36:40 UTC. All customer requests targeting this instance failed. At least seven customers have been affected.
Posted Jul 24, 2025 - 14:30 UTC