[EAM] Accessing workspaces results in errors

Incident Report for SAP LeanIX

Postmortem

Incident Description

On May 19 between 14:56 UTC and 15:34 UTC, many parts of our application’s user interface were not loading, preventing users from accessing the functionality. API’s weren’t affected. No data was lost.

Incident Resolution

Upon receiving error alerts from our monitoring systems, we identified the software change causing the issue and reverted the change. The fix was fully deployed at 15:34 UTC, restoring full functionality for all affected users.

Root Cause Analysis

The change we released relied on a feature of our frontend platform that was not available in all parts of our application. Our automated tests and the code review were not able to catch this issue prior to delivery.

Preventative Measures

To prevent similar issues in the future, we will extend our frontend platform to ensure the missing feature is available in all parts of our application.

Posted May 21, 2025 - 08:12 UTC

Resolved

This incident has been resolved.
Posted May 19, 2025 - 15:52 UTC

Monitoring

We have implemented a fix and have seen full recovery of functionality. We will continue to monitor the situation.
Posted May 19, 2025 - 15:39 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 19, 2025 - 15:32 UTC

Identified

Users may experience errors in accessing their workspaces. The root cause has been identified. We are implementing a solution.
Posted May 19, 2025 - 15:25 UTC
This incident affected: AE Instances, AU Instances, BR Instances, CA Instances, CH Instances, DE instances, EU Instances, JP Instances, SG Instances, UK Instances, and Website.