Delay in factsheet event processing

Incident Report for SAP LeanIX

Postmortem

Incident Description

Between 12 Aug 2025 7:30 UTC and 14 Aug 2025 17:50 UTC, we observed a high number of data events being propagated through SAP LeanIX subsystems. This resulted in a performance degradation where changes made to fact sheet or bookmarks weren’t reflected immediately in some areas of the product like automations, calculations, reports, dashboard navigation, report navigation, diagram navigation, software bill of materials and others. Once all events were processed, fact sheet and bookmark data was again up-to-date in all areas.

Incident Resolution

The incident was resolved by processing all events in all subsystems. To expedite this process, we increased resources where needed in some of the subsystems. We also monitored all systems closely to ensure stable operation.

Root Cause Analysis

The incident occurred because a regular data maintenance operation had accidentally been triggered with incorrect parameters.

Preventative Measures

We have identified and will implement improvements to our data maintenance process to avoid triggering it incorrectly, both on the technical as well as on the operational side.

Posted Aug 18, 2025 - 12:29 UTC

Resolved

This incident has been resolved.
Posted Aug 15, 2025 - 07:16 UTC

Update

We are still monitoring the delays because of fact sheet related event processing of metrics on the software bill of materials.

We continue to actively monitor the situation, and we will provide another update in 16 hours.
Posted Aug 14, 2025 - 16:27 UTC

Update

We are still monitoring the delays because of fact sheet related event processing of metrics on the software bill of materials.

We continue to actively monitor the situation, and we will provide another update in 5 hours.
Posted Aug 14, 2025 - 11:20 UTC

Update

We are still monitoring the delays because of fact sheet related event processing in the automations feature and metrics on the software bill of materials.

We continue to actively monitor the situation, and we will provide another update in 24 hours.
Posted Aug 13, 2025 - 11:57 UTC

Update

Fact sheet-related event processing is back to normal in most areas of the product. However, delays still impact the automations feature and metrics on the software bill of materials.

We continue to actively monitor the situation, and we will provide another update in 3 hours.
Posted Aug 13, 2025 - 08:17 UTC

Monitoring

Fact sheet related events are still processed slower than expected. We continue to monitor the situation.

We will post another update in 16 hours.
Posted Aug 12, 2025 - 15:04 UTC

Update

The situation is back to normal in some regions, and we are still working on the remaining regions.

We will send an additional update in 2 hours.
Posted Aug 12, 2025 - 12:48 UTC

Identified

Fact sheet related events are processed slower than expected, causing delays e.g. in updating the inventory, running automations based on fact sheet change, sending out notifications.

The next update will be provided in 2 hours.
Posted Aug 12, 2025 - 10:48 UTC
This incident affected: AE Instances, AU Instances, CA Instances, CH Instances, DE instances, EU Instances, UK Instances, and US Instances.